Uploaded image for project: 'OpenOLAT'
  1. OpenOLAT
  2. OO-4465

Migration to 14.2 fails in the migrateInfosNotificationsNotDesired routine

    XMLWordPrintable

    Details

      Description

      We are seeing errors in the migration to 14.2 as the latestemailed field is not set in the script (guess it should be nullable in this case):

      javax.persistence.PersistenceException: org.hibernate.PropertyValueException: not-null property references a null or transient value : org.olat.core.commons.services.notifications.model.SubscriberImpl.latestEmailed
              at org.hibernate.internal.ExceptionConverterImpl.convert(ExceptionConverterImpl.java:154) ~[hibernate-core-5.4.10.Final.jar:5.4.10.Final]
              at org.hibernate.internal.ExceptionConverterImpl.convert(ExceptionConverterImpl.java:181) ~[hibernate-core-5.4.10.Final.jar:5.4.10.Final]
              at org.hibernate.internal.ExceptionConverterImpl.convert(ExceptionConverterImpl.java:188) ~[hibernate-core-5.4.10.Final.jar:5.4.10.Final]
              at org.hibernate.internal.SessionImpl.firePersist(SessionImpl.java:708) ~[hibernate-core-5.4.10.Final.jar:5.4.10.Final]
              at org.hibernate.internal.SessionImpl.persist(SessionImpl.java:688) ~[hibernate-core-5.4.10.Final.jar:5.4.10.Final]
              at org.olat.upgrade.OLATUpgrade_14_2_0.migrateInfosNotificationsNotDesired(OLATUpgrade_14_2_0.java:177) [classes/:14.2-SNAPSHOT]
              at org.olat.upgrade.OLATUpgrade_14_2_0.migrateInfosNotificationsNotDesired(OLATUpgrade_14_2_0.java:158) [classes/:14.2-SNAPSHOT]
              at org.olat.upgrade.OLATUpgrade_14_2_0.migrateInfosNotificationsNotDesired(OLATUpgrade_14_2_0.java:132) [classes/:14.2-SNAPSHOT]
              at org.olat.upgrade.OLATUpgrade_14_2_0.doPostSystemInitUpgrade(OLATUpgrade_14_2_0.java:109) [classes/:14.2-SNAPSHOT]
              at org.olat.upgrade.UpgradeManagerImpl$UpgradesTask.run(UpgradeManagerImpl.java:73) [classes/:14.2-SNAPSHOT]
              at org.olat.core.commons.services.taskexecutor.model.DBSecureRunnable.run(DBSecureRunnable.java:42) [classes/:14.2-SNAPSHOT]
              at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_232]
              at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_232]
              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_232]
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_232]
              at java.lang.Thread.run(Thread.java:748) [?:1.8.0_232]
       

        Attachments

          Activity

            People

            Assignee:
            srosse Stéphane Rossé
            Reporter:
            d.haag Daniel Haag
            Tester:
            Mandy Menzel
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: