Uploaded image for project: 'OpenOLAT'
  1. OpenOLAT
  2. OO-43

Can't set quota for blog posts, CP editor image uploads

    XMLWordPrintable

    Details

      Description

      How to reproduce:
      -----------------

      • create blog
      • in blog entry, upload image/video larger than the default quota
        => can't upload
      • create CP in repo with editor
      • in HTML editor, upload image/video larger than the default quota
        => can't upload

      There are two issues here:

      The first problem is that the quota of the OlatRootFolderImpl that represent the repo entry directory is not set at all. The quota is part of the security callback and the security callback in both cases is not set at all.

      The second problem is that the security callback is not properly added to child elements, thus even when set it does not have an effect.

      Another issue is that the admin has no GUI to set the quota in those two cases. Best would be to have it on the repo details view as an additional tab

      See http://groups.google.com/group/openolat/browse_thread/thread/dcb58a30a8b298cc?hl=de

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              srosse Stéphane Rossé
              Reporter:
              gnaegi Florian Gnägi
              Tester:
              Florian Gnägi
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 4 hours Original Estimate - 4 hours
                  4h
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 day, 2 hours, 30 minutes
                  1d 2h 30m