Uploaded image for project: 'OpenOLAT'
  1. OpenOLAT
  2. OO-2212

iOS10 does not play videos caused by iOS10 session id bug

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.5.9, 11.0.10
    • Component/s: Video
    • Labels:
      None

      Description

      How to reproduce

      • Add video using video resource / course element
      • View video using an iOS device running iOS 10
        => Video does not play

      This is caused by an iOS bug. iOS10 does not transmit the session id from the browser. This was already a bug in iOS7 but fixed by Apple in the versions in between. Now they managed to add the bug again.

      See

      http://stackoverflow.com/questions/19215098/html5-video-audio-player-on-mobile-safari-ios-7-ios-10-excludes-cookies
      http://demo.bizify.me/fiddle/cookie/

        Attachments

          Activity

            People

            • Assignee:
              srosse Stéphane Rossé
              Reporter:
              gnaegi Florian Gnägi
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 32 minutes
                32m